Home Engineering Room

Stuck voyage! What to do?

I've heard other people talk about this, but I've been playing for nearly 2 years and this is the first time it's happened to me. I got to the 12-hour dilemma (just barely, only 5 AM to spare), but the dilemma screen won't pop up - it just sits there with the timer going but no new log entries. I've tried logging out and back in both on iOS and Facebook. What solutions are available at this point? Can I even recall it? Should I submit a ticket? Is there some trick to unstick it that I don't know? Any help is appreciated.


  • [7TW] UnkieB[7TW] UnkieB ✭✭✭✭✭
    Some have said reloading a dozen or so times got their voyages unstuck. Never tried it myself, just something I've read here and on the Timelines Discord from time to time.
  • DavideBooksDavideBooks ✭✭✭✭✭
    I reloaded several times on two different devices. But it only happened to me once.
  • Data1001Data1001 ✭✭✭✭✭
    You should be able to at least recall it. That's often what ends up needing to be done. Take screenshots of your loot before you do, and submit a ticket — they will usually give you back the dilithium you spent on the last refill, at the very least.

    Could you please continue the petty bickering? I find it most intriguing.
    ~ Data, ST:TNG "Haven"
  • Yeah, I just recalled it. Hate to miss out on the dilemma, but oh well.
Sign In or Register to comment.