Home Engineering Room

Frozen game - 1430 gmt

Game just froze on me. Restarting, the game freezes with the ‘communicating with starfleet’ message.


  • It is broken.

    Make it go.

    Same problem. Android. UK.
  • D@MND@MN ✭✭✭
    Same here, confirmed with several people across the Western Europe Zone.
  • edited March 2021
    Same here.
  • JiveDutchJiveDutch ✭✭✭
    Here too ... Holland ...
    Steam/Store/PWA all versions..
  • London is pleased to be considered western Europe again and joins you in this saga.
  • HaBlackHaBlack ✭✭✭✭✭
    Same here. Tried iOs, Android and Steam. East Europe
    PlayingSince: 2016-09-16Can we get some more characters from TAS?We finally have Caitians in the game!Character wishlist:
    • Lieutenant M'Ress - got her
    • Amanda Rogers - got her
    • Admiral S'rrel from Star Trek IV: The Voyage Home - not in the game yet
    • Agmar - not in the game yet
    • M'yra - not in the game yet
  • edited March 2021
    Seems to be back up on 'air-fi'
  • OttoOtto ✭✭✭
    Still frozen on all my devices.
  • takes forever for me as well. 5 minutes and counting to get logged in.
    Belgium Area.
  • ShanShan ✭✭✭✭✭
    No issue on our end, I hope this will get resolved soon and I am sorry for the inconvenience this is causing you :(
  • Zombie Squirrel [Retired]Zombie Squirrel [Retired] ✭✭✭✭✭
    edited March 2021
    I had issues earlier via WiFI(Vodafone), but when i switched to Mobile(T-Mobile)
    it worked. Looks like another „Routing Issue“, depending on which carrier you use.
  • LjofaLjofa ✭✭✭
    It’s back but going very slowly. No other issues with other games/apps. Hmmm, this’ll make the start of the weekends event fun...
  • JassadaJassada ✭✭✭
    Can‘t get the App to start now, it was working before for me... The event... :/
  • JassadaJassada ✭✭✭
    Complaining here seems to have done the trick! :)
Sign In or Register to comment.