Home Engineering Room

Google Play Store Payment issues

Wondering if anyone else has this issue - yesterday morning, bought the 10 for $10 (plus Citation) pack using my linked Google Play account, no issue. Been using this for years. Then early this morning, went for the $25 ultimate campaign track, and it doesn't work - "there are tribbles in the system". In fact, nothing I attempted to purchase, whether from the game or the store site work.

However, when I run another game (AFK Heros) there is no issue using the account there - made a few small test purchases and they worked as expected. So my Google Play account seems to be okay and working on my phone. But not with Timelines.

Any ideas?

Comments

  • @Admiral Hess Yes you have to wait 24 hours after putting new money on your account. And the only place I have the problem is STT. They say it is google play, but I can purchase anything anywhere else, so the problem has to be with Wicked Realms. My issues started after they opened the Web Store, and I won't go to the web store
  • Update - after a day or so, it has magically cleared itself up. For the record, I had not added money to the account recently, and there were sufficient funds for the purchase. Very odd.
Sign In or Register to comment.