Home Engineering Room

Unable to login / possibly corrupted player data


I have been unable to sign in to the game for 5 days. This is what happened:

I made an attempt to swap fleets (around 2023-02-24 6:20 PM UTC), but when I was joining the new fleet, the UI got unresponsive, and I cannot get back in the game since then. On top of that, if other players select my profile in the game, their clients get unresponsive too.

I tried everything on client side:
  • clearing local files
  • reinstalling the game
  • switching from alt account (note: my alt account works like a charm though)
  • restarting device
  • downloading from different app store (Play Store, Galaxy Store)
  • using different platform (Android, Steam)
  • different device
  • different network
  • different location (different country via VPN)

no success.

I cannot even retrieve my player.json data via web browser, I get this error message and call stack instead:
NoMethodError (undefined method `[]' for nil:NilClass):
app/controllers/player_controller.rb:149:in `index'
app/controllers/application_controller.rb:69:in `record_client_api'
lib/execution_scope.rb:14:in `call'
lib/execution_scope.rb:14:in `block in with_scope'
lib/callback_manager.rb:183:in `call'
lib/callback_manager.rb:183:in `wrap_operation'
lib/execution_scope.rb:13:in `with_scope'
app/controllers/application_controller.rb:56:in `with_execution_scope'
app/controllers/application_controller.rb:23:in `block in process_action'
app/controllers/application_controller.rb:22:in `process_action'
lib/rails_same_site_cookie/middleware.rb:13:in `call'

So I am 99.9% sure that the issue is on server side, my best guess is my player data got corrupted in an unexpected way and the code cannot handle it properly.

Has anyone experienced similar issue before? Is there any chance to fix my account? I know it is probably a very unique issue, and it would be too costly to investigate it by the laid-off and overwhelmed WRG staff, but the support team is unresponsive and I would appreciate any help.

I have a backup copy of my player.json from a week earlier if it helps.



  • Try again please, it may be cleared up now.
  • WizzdomeWizzdome ✭✭✭
    I just started having the same issue... it hangs "Turbolifting to the Bridge Powering up warpcore" (progress bar looks full but could be 99.9) I tried on my tablet and on my phone... neither work, however from the microsoft windows version i was able to login. Also if i start the game on another device I get the notification that it was just logged in by another device so not sure what is causing the hangup... Im gonna just let it sit there for a few hours and see if it goes through, but I doubt it...
  • I have the exact same symptoms as Wizzdome. Also tried on two different android devices but it works on the windows version.
  • edited March 2
    I am also having a problem loging in.
    I can download the game from a new place and create a new account but as soon as I try to sign in under my regular account it hangs up at the "Turbolifting to the bridge" and won't go past.
    I assume something is messed up on the server end but I don't know where to go for help.
    I've been working this account diligently since 2018 and really don't want to start over.
  • Same issue hanging on Android. Flushed cache, and reinstalled twice with no improvement.
  • There was a latency event this morning that has since been resolved. Please submit a ticket if you continue experiencing issues. "HaltIn"'s issue was very specific, and likely different from the other reports above.
  • Hi! The developers just send out an in-game mail that will contain one voyage revival token and 250 chronitons to compensate for the inconvenience! check your inbox.
  • Riker's islan{DD}Riker's islan{DD} ✭✭✭✭
    The game is still suffering from severe lag - logon taking 2 - 3 minutes after error messages and once in, its completley unplayable
  • Can't even get it to log in
  • AviTrekAviTrek ✭✭✭✭✭
    Hi! The developers just send out an in-game mail that will contain one voyage revival token and 250 chronitons to compensate for the inconvenience! check your inbox.

    The game is still down.

    Also, given the timing of this after the staff reductions, I am more curious what is being done so events can launch without a problem next time. The voyage tokens are nice, but I'd rather have confidence that future events can launch.
  • SimsSims ✭✭✭
    I got booted out whilst claiming my sorrychrons!
  • Hi! The developers just send out an in-game mail that will contain one voyage revival token and 250 chronitons to compensate for the inconvenience! check your inbox.

    I received it but can't open it.
  • WRG Matt wrote: »
    Try again please, it may be cleared up now.

    It did resolve my problem, I can log in, many thanks!!!
  • WizzdomeWizzdome ✭✭✭
    Still not able to login via android. I am unable to use windows pc for lengths of time, but i will submit a ticket there, I was hoping that posting on the forum would be not only more direct, but easier since i can only login from windows store app... hope this gets straightened soon, as my game progress is hurting bad... missing out on lots especially when i am so low on fed creds i cant build a crew item lol... any way best wishes, if there is anything i can do to help in diagnosing or remedying this problem i am 100 % willing...
  • Same here Wizzdome. After the sorry chrons yesterday I tried again and still gets stuck at turbolifting to the bridge. Updated my ticket saying that I still had the problem and got a message this morning that said "Hey, we fixed this and sent you chrons!" Please read my updates to the ticket.

    So this morning still can't login on Android which makes it pretty hard to keep up on the faction event at work. Also losing all those ad warps that I use every day.
  • WizzdomeWizzdome ✭✭✭
    edited March 4
    Have the devs abandoned this post marking it fixed? Just curious since the OP's problem was solved it seems like people with similar cases were not even addressed other than telling us to send in a ticket which i did... still waiting to hear back though... havent checked the login today... I will keep posting here till I have a solution anyhow... thanks for the update.

    Still no response from ticket, and negative on the login from android still...
    Final Update:
    Back online after sending a ticket... hope everyone else gets back on too... and thank you.
Sign In or Register to comment.