Home Past Anomalies

Cadet Challenge locking up

Every time I try to enter/play the Cadet Challenge today, a Server error notice pops up. Unable to play them. Had to bail in the middle of one. Anyone else having that problem?
Hurry up before those things eat Guy!


  • ShanShan admin
    Could you please try again?
    I wonder if it could have been caused by the server push that was done earlier.
  • Zombie Squirrel Zombie Squirrel ✭✭✭✭✭
    Had the same when i tried to send shuttles. But was clearly cause of server push. Now all works as intended? ;)
  • Darth SkippyDarth Skippy ✭✭✭✭
    Ok. Logged back in and It just ran fine. Entered same lvl, same episode, Flesh and Blood.

    Earlier today in the middle of a ship battle, the same error notice appeared, but it didn't lock that up, i was able to finish.
    Hurry up before those things eat Guy!
  • ShanShan admin
    Glad to hear, sorry about the error earlier, if you lost your ticket because of it please let Support know. Thank you!
Sign In or Register to comment.